1099. Build A Binary Search Tree (30)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

    Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

    Input Specification:

    Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

    Output Specification:

    For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

    Sample Input:
    9
    1 6
    2 3
    -1 -1
    -1 4
    5 -1
    -1 -1
    7 -1
    -1 8
    -1 -1
    73 45 11 58 82 25 67 38 42
    
    Sample Output:
    58 25 82 11 38 67 45 73 42
    

考察二叉搜索的中序遍历。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
struct node
{
    int data;
    int left,right;
}s[101];
int n,l[101],c;
void inorder(int r)
{
    if(r == -1)return;
    inorder(s[r].left);
    s[r].data = l[c ++];
    inorder(s[r].right);
}
void level()
{
    int q[101] = {0},head = 0,tail = 1;
    while(head < tail)
    {
        if(s[q[head]].left != -1)q[tail ++] = s[q[head]].left;
        if(s[q[head]].right != -1)q[tail ++] = s[q[head]].right;
        if(head)printf(" %d",s[q[head ++]].data);
        else printf("%d",s[q[head ++]].data);
    }
}
int main()
{
    scanf("%d",&n);
    for(int i = 0;i < n;i ++)
    {
        scanf("%d%d",&s[i].left,&s[i].right);
    }
    for(int i = 0;i < n;i ++)
        scanf("%d",&l[i]);
    sort(l,l + n);
    inorder(0);
    level();
}
View Code

猜你喜欢

转载自www.cnblogs.com/8023spz/p/8993621.html