C - Max Sum (DP最大连续子序列和)

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
const int N=1e5+5;
int a[N];
int dp[N];

int main(void)
{
	int t;
	scanf("%d",&t);
	for(int k=1;k<=t;k++)
	{
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		memset(dp,0,sizeof(dp));
		int head=1,tail=1,mmax=a[1];//?!=1?!
		dp[1]=a[1];
		int l=1;
		for(int i=2;i<=n;i++)
		{
			//dp[i]=max(dp[i-1]+a[i],a[i]);
			if(dp[i-1]+a[i]>=a[i])
			{
				dp[i]=dp[i-1]+a[i];
			}
			else
			{
				dp[i]=a[i];
				l=i;
			}
			if(dp[i]>mmax)
			{
				mmax=dp[i];
				tail=i;	
				head=l;
			}
		}
		printf("Case %d:\n%d %d %d\n",k,mmax,head,tail);
		if(k!=t)
		printf("\n");
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/nucleare/article/details/80987525