HDU-4310 Hero (贪心)

Hero

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2131    Accepted Submission(s): 960


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
 

 

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
 

 

Output
Output one line for each test, indicates the minimum HP loss.
 

 

Sample Input
1 10 2 2 100 1 1 100
 

 

Sample Output
20 201
 

Dota游戏,只有你一个人需要打败n个人

你的攻击只有一点,也就是你打敌方hero一下只能打掉他一滴血,但是你的hp是无限的

只要某个boss的hp>0,他就可以对你造成伤害

回合制游戏,你打他,他也打你,同时发生,不存在你先打死boss,boss对你攻击无效的情况

问你如何攻击才能使损失的血量最小


简单贪心,对DPS/HP进行排序,从大到小选出你要攻击的对象,然后利用计算就能得到答案


#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<set>
using namespace std;

struct boss
{
    int dps;
    int hp;
} a[150];

int cmp(boss a,boss b)
{
   return  a.dps*b.hp>b.dps*a.hp;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
         int sumdps=0;
        for(int i=0; i<n; i++)
          {
              scanf("%d%d",&a[i].dps,&a[i].hp);
              sumdps+=a[i].dps;
          }
        sort(a,a+n,cmp);
        int cnt=0;
        for(int i=0;i<n;i++)
        {
             //printf("%d %d\n",a[i].dps,a[i].hp);
            cnt+=sumdps*a[i].hp;
           // printf("%d\n",cnt);
            sumdps-=a[i].dps;
        }
        printf("%d\n",cnt);

    }
     return 0;
}



猜你喜欢

转载自blog.csdn.net/AC_Meiko/article/details/80084723