HDU 2654 - Become A Hero (欧拉函数模板)

版权声明:欢迎转载 https://blog.csdn.net/l18339702017/article/details/81878831

Become A Hero

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 287    Accepted Submission(s): 79


 

Problem Description

Lemon wants to be a hero since he was a child. Recently he is reading a book called “Where Is Hero From” written by ZTY. After reading the book, Lemon sends a letter to ZTY. Soon he recieves a reply.

Dear Lemon,
It is my way of success. Please caculate the algorithm, and secret is behind the answer. The algorithm follows:
Int Answer(Int n)
{
.......Count = 0;
.......For (I = 1; I <= n; I++)
.......{
..............If (LCM(I, n) < n * I)
....................Count++;
.......}
.......Return Count;
}
The LCM(m, n) is the lowest common multiple of m and n.
It is easy for you, isn’t it. 
Please hurry up!
ZTY

What a good chance to be a hero. Lemon can not wait any longer. Please help Lemon get the answer as soon as possible. 

 

Input

First line contains an integer T(1 <= T <= 1000000) indicates the number of test case. Then T line follows, each line contains an integer n (1 <= n <= 2000000).

 

Output

For each data print one line, the Answer(n).

 

Sample Input

 

1 1

 

Sample Output

 

0

题意 : 求 1 ~ n 中与 n 不互质的数的个数

#pragma GCC optimize(2)
#include<bits/stdc++.h>
using namespace std;
#define clr(a) memset(a,0,sizeof(a))
#define line cout << "------------" << endl

typedef long long ll;
const int maxn = 2e6 + 10;
const int MAXN = 1e6 + 10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1010;

int phi[maxn];
void Euler(){
    phi[1] = 1;
    for(int i = 2; i < maxn; i++){
        phi[i] = i;
    }
    for(int i = 2; i < maxn; i++){
        if(phi[i] == i){
            for(int j = i; j < maxn; j += i){
                phi[j] = phi[j] / i * (i - 1);
            }
        }
    }
}

int main(){
	Euler();
	int t;
	cin>>t;
	while(t--){
		int n;
		scanf("%d",&n);
		printf("%d\n",n - phi[n]);
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/81878831
今日推荐