hdu 4310 hero

题目链接https://vjudge.net/contest/235899#problem/Q

题目如下

When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input

The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output

Output one line for each test, indicates the minimum HP loss.

Sample Input

1
10 2
2
100 1
1 100

Sample Output

20
201

这是一道运用贪心的题,enemy hero的dps可看做付出的代价,enemy hero的hp可看做收益,当然要付出少,收益大才叫贪心

所以用DPSi/HPi,按从大到小排序

扫描二维码关注公众号,回复: 2700821 查看本文章

但是,有一点要注意,由于题目说DPS和HP都是integer,所以可能用int型,但是int型做除法,有误差,为了避免这一点

DPSi/HPi>DPSj/HPj 可化为 DPSi*HPj>DPSj*HPi

代码如下

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef struct
{
	int dfs,hp;
} hero;
hero a[30];
int n;
bool compare(hero a,hero b)
{
	return a.dfs*b.hp>b.dfs*a.hp;//注意!
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		int sum=0;
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].dfs,&a[i].hp);
		}
		sort(a,a+n,compare);
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<a[i].hp;j++)
			{
				for(int m=0;m<n;m++)
			    sum=sum+a[m].dfs;
			}
			a[i].dfs=0;
		}
		printf("%d\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41626975/article/details/81460058