中国石油大学个人训练赛第七场 c题(floyd算法)

问题 C: Restoring Road Network

时间限制: 1 Sec  内存限制: 128 MB
提交: 940  解决: 206
[提交] [状态] [讨论版] [命题人:admin]

题目描述

In Takahashi Kingdom, which once existed, there are N cities, and some pairs of cities are connected bidirectionally by roads. The following are known about the road network:
People traveled between cities only through roads. It was possible to reach any city from any other city, via intermediate cities if necessary.
Different roads may have had different lengths, but all the lengths were positive integers.
Snuke the archeologist found a table with N rows and N columns, A, in the ruin of Takahashi Kingdom. He thought that it represented the shortest distances between the cities along the roads in the kingdom.
Determine whether there exists a road network such that for each u and v, the integer Au,v at the u-th row and v-th column of A is equal to the length of the shortest path from City u to City v. If such a network exist, find the shortest possible total length of the roads.

Constraints
1≤N≤300
If i≠j, 1≤Ai,j=Aj,i≤109.
Ai,i=0

输入

Input is given from Standard Input in the following format:
N
A1,1 A1,2 … A1,N
A2,1 A2,2 … A2,N

AN,1 AN,2 … AN,N
 

输出

If there exists no network that satisfies the condition, print -1. If it exists, print the shortest possible total length of the roads.

样例输入

3
0 1 3
1 0 2
3 2 0

样例输出

3

提示

The network below satisfies the condition:
City 1 and City 2 is connected by a road of length 1.
City 2 and City 3 is connected by a road of length 2.
City 3 and City 1 is not connected by a road.

题目大意:

给你一个邻接矩阵e[i][j],让你判断邻接矩阵e[i][j](i,j是任意的)上的值是否是i点到j点的最短路,如果不是,输出-1,如果是,输出整个图的最短总路径。

思路:

用floyd算法跑一遍给定的邻接矩阵,一共有三种情况:

一:中转路径小于直接路径      输出-1,直接结束。

二:中转路径等于直接路径      continue。

三:中转路径大于直接路径      类加上直接路径。

最后输出累加的结果。

代码:

#include<bits/stdc++.h>
#define MAXN 301
using namespace std;
int n;
long long e[MAXN][MAXN];
long long ans=0;//累加结果
int floyd()
{
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=i;j++)
        {
            bool flag=1;
            for(int k=1;k<=n;k++)
            {
                if((e[i][k]+e[k][j])<e[i][j])//给出的邻接矩阵不是任意两点都是最短路
                {
                    cout<<"-1";
                    return 0;
                }
                else if(i!=k&&j!=k&&(e[i][k]+e[k][j]==e[i][j]))//如果中转路径等于直接路径,我们不把e[i][j]加入到ans中去,而是加入e[i][k]和e[k][j]
                    flag=0;
            }
            if(flag)//如果上面两个条件都没有满足,说明给定的e[i][j]的值就是i点到j点的最短路,累加上
               ans+=e[i][j];
        }
    }
    return 1;
}
int main()
{
    cin>>n;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
             cin>>e[i][j];
    if(floyd())
       cout<<ans;
}

猜你喜欢

转载自blog.csdn.net/qq_40938077/article/details/81324497
今日推荐