【POJ 2407】Relatives 欧拉函数

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:输入一个n,求出所有小于n且与n互质的数的个数,即求gcd(i,n)=1 。欧拉函数的基本应用。

代码:

#include<iostream>
using namespace std;

int euler(int n)             //    欧拉函数模板
{
	int res=n,i;
	for(i=2; i*i<=n; i++)
		if(n%i==0) 
		{
			res=res/i*(i-1);
			while(n%i==0)
				n/=i;
		}
	if(n>1)
		res=res/n*(n-1);
	return res;
}
int main() 
{
	int n;
	while(cin>>n&&n)
		cout<<euler(n)<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Xylon_/article/details/81484130