Farey Sequence POJ - 2478(欧拉函数)

Farey Sequence POJ - 2478

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn. 

Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) —- the number of terms in the Farey sequence Fn.
Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题意:

给一个数n让求Fn这个集合中有多少个数,Fn是1-n互质的数构成的真分数(分子小于分母)

分析:

给定1个n,我们可以从1-n遍历,每次看1-i范围内和i互质的数有多少个其实就能构成多少个真分数,然后不断求和即答案,而1-i范围内有多少个和i互质的数就是求欧拉函数,打个表预处理一下就行了。

注意答案用longlong存,因为会超int

code:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
typedef long long ll;
const int maxn = 1e6+10;
int phi[maxn];
void getphi(){
    for(int i = 2; i < maxn; i++){
        phi[i] = i;
    }
    phi[1] = 1;
    for(int i = 2; i < maxn; i++){
        if(phi[i] == i){
            for(int j = i; j < maxn; j += i){
                phi[j] = phi[j] / i * (i - 1);
            }
        }
    }
}
ll num[maxn];
void init(){
    getphi();
    memset(num,0,sizeof(num));
    num[2] = 1;
    for(int i = 3; i < maxn; i++){
        num[i] = num[i-1] + phi[i];
    }
}
int main(){
    init();
    int n;
    while(scanf("%d",&n) != EOF && n){
        printf("%lld\n",num[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/codeswarrior/article/details/81119010