poj2407 Relatives(欧拉函数 水题)

日常水题传送门:Relatives

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:

求小于n,且与n互质的数的个数

思路:

直接求出n的phi值,通过欧拉函数直接得到答案。

AC代码:

//#include <bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N = 1e6 + 7;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
int get_phi(int n)
{
    int res = n;
    for(int i = 2;i * i <= n;++i){
        if(n % i == 0){
            res = res / i * (i - 1);
            while(n % i == 0) n /= i;
        }
    }
    if(n > 1) res = res / n * (n - 1);
    return res;
}
int main()
{
    int n;
    while(scanf("%d",&n) != EOF && n){
        printf("%d\n",get_phi(n));
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41791981/article/details/82770935