poj2407 Relatives ——欧拉函数

题目描述

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
输入
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
输出
For each test case there should be single line of output answering the question posed above.
样例输入
7
12
0
样例输出
6
4

题意
给你数 x,求φ(x),多组输入

题解
根据公式 当 x=a1^k1+a2^k2+…+an^kn,φ(x)=x*(1-1/a1) (1-1/a2)…*(1-1/an)
利用公式就可以在 O(sqrt(x)) 的时间内求出φ(x)

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int n;
int phi(int x){
    int num=x;
    for(int i=2;i*i<=x;i++)
        if(x%i==0){
            num=num/i*(i-1);
            while(x%i==0) x/=i;}
    if(x>1) num=num/x*(x-1);
    return num;}
int main(){
    while(~scanf("%d",&n)){
        if(!n) return 0;
        printf("%d\n",phi(n));}
} 

猜你喜欢

转载自blog.csdn.net/chm_wt/article/details/81461733