HDU1576 A/B 费马小定理

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1369    Accepted Submission(s): 1045


 

Problem Description

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

 

2 1000 53 87 123456789

Sample Output

 

7922 6060

思路:由gcd(B,9973)=1可知,B与9973互质,且为质数,因此可以用费马小定理来求出B对9973的乘法逆元;

(A/B)%mod==(A*B的逆元)%mod.

代码:

#include <iostream>
using namespace std;
typedef long long ll;
int mod=9973;
ll quickpow(ll a,ll b)
{
        ll res = 1;
	a = a % mod;
        while(b)
        {
        if(b & 1) res = res * a % mod;
        a = a * a % mod;
        b >>= 1;
        }
        return res;
}
int main()
{
	int t,n,b,ans;
	cin>>t;
	while(t--)
	{
		cin>>n>>b;
		ans=quickpow(b,mod-2);
		cout<<ans*n%mod<<endl;
	}
	return 0;
}
 
 

猜你喜欢

转载自blog.csdn.net/KK_2018/article/details/81208363