POJ 2060(最小路径覆盖 = | G | - 最大匹配数)

Taxi Cab Scheme

Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 7452   Accepted: 3043

Description

Running a taxi station is not all that simple. Apart from the obvious demand for a centralised coordination of the cabs in order to pick up the customers calling to get a cab as soon as possible,there is also a need to schedule all the taxi rides which have been booked in advance.Given a list of all booked taxi rides for the next day, you want to minimise the number of cabs needed to carry out all of the rides. 
For the sake of simplicity, we model a city as a rectangular grid. An address in the city is denoted by two integers: the street and avenue number. The time needed to get from the address a, b to c, d by taxi is |a - c| + |b - d| minutes. A cab may carry out a booked ride if it is its first ride of the day, or if it can get to the source address of the new ride from its latest,at least one minute before the new ride's scheduled departure. Note that some rides may end after midnight.

Input

On the first line of the input is a single positive integer N, telling the number of test scenarios to follow. Each scenario begins with a line containing an integer M, 0 < M < 500, being the number of booked taxi rides. The following M lines contain the rides. Each ride is described by a departure time on the format hh:mm (ranging from 00:00 to 23:59), two integers a b that are the coordinates of the source address and two integers c d that are the coordinates of the destination address. All coordinates are at least 0 and strictly smaller than 200. The booked rides in each scenario are sorted in order of increasing departure time.

Output

For each scenario, output one line containing the minimum number of cabs required to carry out all the booked taxi rides.

Sample Input

2
2
08:00 10 11 9 16
08:07 9 16 10 11
2
08:00 10 11 9 16
08:06 9 16 10 11

Sample Output

1
2

题意:给你一些出租车预定消息,包括开始时间,起点坐标以及终点坐标,如果一辆出租车在处理完当前预定后,能够提前1分钟以上到达下一个预定订单的起点,那么出租车可以接着进行下个订单,问处理完所有订单最少需要多少出租车。 
思路:要求最少的出租车数目,那么每辆被派出的出租车要尽可能完成多的订单。 
那么不妨假设,开始时我们对于每个订单都派出一辆出租车,我们就需要n辆出租,但是为了节约,如果我们让一辆出租车在完成了一个订单以后,继续去找下一个可以执行的订单,这样,我们每匹配到一个订单,出租车的数量就会减1 
题目就被我们转化成了一个二分匹配问题,我们只需要对每个订单标号,存在匹配关系的订单进行建边,然后二分匹配,答案就是:订单数-最大匹配数 

AC代码:

扫描二维码关注公众号,回复: 2546206 查看本文章
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;

const int maxn = 505;
int mp[maxn][maxn];
int vis[maxn];
int link[maxn];
struct r{
    int _time,a,b,c,d;
}ride[maxn];
int n;

bool isok(r A,r B){
    int cost = abs(A.a - A.c) + abs(A.b - A.d);
    int cost2 = abs(A.c - B.a) + abs(A.d - B.b);
    return A._time + cost + cost2 + 1 <= B._time;
}

bool _find(int s){
    for(int i = 1;i <= n;i ++){
        if(!vis[i] && mp[s][i]){
            vis[i] = 1;
            if(link[i] == -1 || _find(link[i])){
                link[i] = s;
                return true;
            }
        }
    }
    return false;
}

int hungry(){
    int ans = 0;
    for(int i = 1;i <= n;i ++){
        memset(vis,0,sizeof(vis));
        ans += _find(i);
    }
    return ans;
}

int main()
{
    int t; scanf("%d",&t);
    while(t --){
        memset(mp,0,sizeof(mp));
        memset(link,-1,sizeof(link));
        scanf("%d",&n);
        int hour,mi;
        for(int i = 1;i <= n;i ++){
            scanf("%d:%d%d%d%d%d",&hour,&mi,&ride[i].a,&ride[i].b,&ride[i].c,&ride[i].d);
            ride[i]._time = hour * 60 + mi;
        }
        for(int i = 1;i <= n;i ++){
            for(int j = i + 1;j <= n;j ++){
                if(isok(ride[i],ride[j]))
                    mp[i][j] = 1;
            }
        }
        int ans = hungry();
        printf("%d\n",n - ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_O_ac/article/details/81394688