POJ 2594 Treasure Exploration 最小路径重复点覆盖

一、内容

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.
As an ICPCer, who has excellent programming skill, can your help EUC? 

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros. 

Output

For each test of the input, print a line containing the least robots needed. 

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

二、思路

  • 问最少的士兵使全部的点都被访问过。 求一下最小路径重复点覆盖即可 = 点总数 - 最大匹配数。

三、代码

#include <cstdio>
#include <cstring>
using namespace std;
const int N = 505;
int n, m, u, v, mat[N], g[N][N];
bool vis[N];
bool dfs(int u) {
	for (int v = 1; v <= n; v++) {
		if (vis[v] || !g[u][v]) continue; vis[v] = true;
		if (!mat[v] || dfs(mat[v])) {
			mat[v] = u; return true;
 		}
	}
	return false;
}
int main() {
	while (scanf("%d%d", &n, &m), n) {
		memset(mat, 0, sizeof(mat));
		memset(g, 0, sizeof(g));
		for (int i = 1; i <= m; i++) {
			scanf("%d%d", &u, &v); g[u][v] = 1;
		}
		for (int k = 1; k <= n; k++) {
			for (int i = 1; i <= n; i++) {
				for (int j = 1; j <= n; j++) g[i][j] |= g[i][k] && g[k][j]; 
			}
		}
		int ans = n;
		for (int i = 1; i <= n; i++) {
			memset(vis, false, sizeof(vis));
			if (dfs(i)) ans--;
		}
		printf("%d\n", ans);
	}
 	return 0;
} 
发布了471 篇原创文章 · 获赞 481 · 访问量 7万+

猜你喜欢

转载自blog.csdn.net/qq_41280600/article/details/104537351
今日推荐