POJ 2594 Treasure Exploration(最小路径覆盖)

                                                                        Treasure Exploration

Time Limit: 6000MS   Memory Limit: 65536K
Total Submissions: 9385   Accepted: 3823

Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

题目大意:一个n个点的有向图,问最少放几个机器人能走完整个图。

最小路径覆盖=点数-最大匹配数

先用floyd把整个图都跑一遍得出所有能走的边,然后建图跑匈牙利

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=510;
int n,m;
int map[maxn][maxn];
bool vis[maxn];
int match[maxn];
bool dfs(int node)
{
    for(int i=1;i<=n;i++)
    {
        if(!vis[i]&&map[node][i])
        {
            vis[i]=true;
            if(match[i]==-1||dfs(match[i]))
            {
                match[i]=node;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(!n&&!m) break;
        memset(map,0,sizeof(map));
        for(int i=0;i<m;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            map[u][v]=1;
        }
        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(map[i][k]&&map[k][j]&&!map[i][j])
                    {
                        map[i][j]=1;
                    }
                }
            }
        }
        int ans=0;
        memset(match,-1,sizeof(match));
        for(int i=1;i<=n;i++)
        {
            memset(vis,false,sizeof(vis));
            if(dfs(i))
            {
                ans++;
            }
        }
        cout<<n-ans<<endl;
    }
    return 0;
}                                                              

猜你喜欢

转载自blog.csdn.net/qq_37943488/article/details/81093802