poj-2594(可相交最小路径覆盖)

题目:POJ - 2594 

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you. 
Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure. 
To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points, which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point. 
For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars. 
As an ICPCer, who has excellent programming skill, can your help EUC?

Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.

Output

For each test of the input, print a line containing the least robots needed.

Sample Input

1 0
2 1
1 2
2 0
0 0

Sample Output

1
1
2

题意:n个点,m条有向边,问最少需要多少个机器人可以走完所有点。每一条路径上不能有重复点,但是不同路径上可以有重复点。

分析:以往的最小路径覆盖要求不同路径之间不能有重复点,但是这道题却有;

所以不能直接建图跑最大匹配,需要先将任意之间可达的点连一条边,这里利用Floyd求传递闭包,这样就可以不经过重复点,但是可以到达本来能到达的点。再在新图上跑最大匹配。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

const int maxn = 510;
const int maxm = 2510;
int un,vn;
int g[maxm][maxm];
int linker[maxn];
bool used[maxn];
int n;
int mm;
bool dfs(int u)
{
    for(int v = 1;v <= vn;v ++)
    {
        if(g[u][v] && !used[v])
        {
            used[v] = true;
            if(linker[v] == -1 || dfs(linker[v]))
            {
                linker[v] = u;
                return true;
            }
        }
    }
    return false;
}

int hungary()
{
    int res = 0;
    memset(linker,-1,sizeof(linker));
    for(int u = 1;u <= un;u ++)
    {
        memset(used,false,sizeof(used));
        if(dfs(u)) res ++;
    }
    return res;
}

int main()
{

    while(cin >> n >> mm && n + mm)
    {
        int u,v;
        memset(g,0,sizeof(g));
        while(mm --)
        {
            cin >> u >> v;
            g[u][v] = 1;
        }
        un = vn = n;
        for(int k = 1;k <= n;k ++)
        {
            for(int i = 1;i <= n;i ++)
            {
                for(int j = 1;j <= n;j ++)
                {
                    if(g[i][k] && g[k][j])
                        g[i][j] = 1;
                }
            }
        }
        int ans = hungary();
        ans = n - ans;
        cout << ans << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/86564298