POJ - 3661 Running dp


点击打开链接

Running
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7317   Accepted: 2751

Description

The cows are trying to become better athletes, so Bessie is running on a track for exactly N (1 ≤ N ≤ 10,000) minutes. During each minute, she can choose to either run or rest for the whole minute.

The ultimate distance Bessie runs, though, depends on her 'exhaustion factor', which starts at 0. When she chooses to run in minute i, she will run exactly a distance of Di (1 ≤ Di ≤ 1,000) and her exhaustion factor will increase by 1 -- but must never be allowed to exceed M (1 ≤ M ≤ 500). If she chooses to rest, her exhaustion factor will decrease by 1 for each minute she rests. She cannot commence running again until her exhaustion factor reaches 0. At that point, she can choose to run or rest.

At the end of the N minute workout, Bessie's exaustion factor must be exactly 0, or she will not have enough energy left for the rest of the day.

Find the maximal distance Bessie can run.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 contains the single integer: Di

Output

* Line 1: A single integer representing the largest distance Bessie can run while satisfying the conditions.
 

Sample Input

5 2
5
3
4
2
10

Sample Output

9

Source

USACO 2008 January Silver


设dp[i][j]表示第i分钟疲劳度为j时的最大步行距离

首先对于dp[i][0],显然可以由dp[i-1][0](继续休息)和dp[i-j][j](从第i-j分钟休息到第i分钟)状态转移得来

然后对于一般的dp[i][j]=dp[i-1][j-1]得来

也就是说实际上状态的转移只有在疲劳度j=0的时候才会发生

代码如下

#include<iostream>
#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<algorithm>
#include<queue>
#include<set>
#include<cstdio>
#include<functional>
#include<iomanip>
#include<cmath>
#include<stack>
using namespace std;
const int maxn = (int)(1e5) + 100;
const int inf = 0x3f3f3f3f;
const int mod = 2520;
const double eps = 1e-3;
typedef long long LL;
typedef unsigned long long ull;
int dp[11111][555];
int d[11111];
int main() {
	//freopen("E:\\test.txt", "r", stdin);
	int n, m;
	while (~scanf("%d%d", &n, &m)) {
		for (int i = 1; i <= n; i++)
			scanf("%d", &d[i]);
		memset(dp, 0, sizeof(dp));
		for (int i = 1; i <= n; i++) {
			dp[i][0] = dp[i - 1][0];
			for (int j = 1; j <= m; j++) {
				if (i - j >= 0) {
					dp[i][0] = max(dp[i][0], dp[i - j][j]);
				}
				dp[i][j] = dp[i - 1][j - 1] + d[i];
			}
		}
		printf("%d\n", dp[n][0]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiuya19/article/details/79827564