HDU-2560 Buildings

HDU-2560 Buildings

Time Limit : 2000/1000ms (Java/Other)
Memory Limit : 32768/32768K (Java/Other)

Problem Description

We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.
  这里写图片描述

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.

Output

Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.

Sample Input

2
2 2
1 1
0 0
3 3
1 0 1
0 0 1
1 1 0

Sample Output

2
5


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=2560

分析

题意:题目那么短,那么简单,统计绿色方块的数量…..

思路:emmmm…直接统计就好了,碰到绿色的就+1,连数组都不用开,贼水的一道题

代码

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int n,x,y,num;
    cin>>n;
    while (n--)
    {
        int sum=0;
        cin>>x>>y;
        for (int i=0;i<x;i++)
            for (int j=0;j<y;j++)
            {
                cin>>num;
                if (num==1)
                    sum++;
            }
        cout<<sum<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/bestfm/article/details/80099799