poj1840 等式成立组合问题(需要哈希~)

Eqs
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 17323   Accepted: 8503

Description

Consider equations having the following form: 
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source

Romania OI 2002

题意很好理解,注意数组下标不要出现负数,会停止运行的。

先将方程变化成-(a4*x4^3+a5*x5^3) = a1*x1^3+a2*x2^3+a3*x3^3,缩短了时间复杂度,否则直接五个嵌套for循环必然会超时的其次,将左面的式子结果作为下标,那么hash数组也就是s数组的上界就取决于a4 a5 x4 x5的组合,四个量的极端值均为50,因此上界为 50*50^3+50*50^3=12500000,由于下标也可能为负数,因此我们对s[]的上界进行扩展,扩展到25000001,当结果小于等于0的时候加上25000001,负数的部分就会转化为12500001~25000001.

一个需要记住的小常识65536KB 差不多能开int型数组1677w左右,所以应该用short型数组,就可以开到25000001了。char也可以,就是不能int会爆内存。

#include<stdio.h>
#include<string.h>
int a1,a2,a3,a4,a5;
short s[25000005];
int main()
{
    while(~scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5))
    {memset(s,0,sizeof(s));
        for(int i=-50;i<=50;i++)
        {
            if(i==0)continue;
            for(int j=-50;j<=50;j++)
            {
                if(j==0)continue;
                int u=-a4*i*i*i-a5*j*j*j;
                if(u<=0)u+=25000001;
                s[u]++;

            }
        }
        int sum=0;
        for(int i=-50;i<=50;i++)
        {      if(i==0)continue;
            for(int j=-50;j<=50;j++)
            {    if(j==0)continue;
                for(int k=-50;k<=50;k++)
                {if(k==0)continue;
                int u=a1*i*i*i+a2*j*j*j+a3*k*k*k;
                if(u<=0)u+=25000001;
                sum+=s[u];

                }
            }
        }
        printf("%d\n",sum);
    }
}

猜你喜欢

转载自blog.csdn.net/wrwhahah/article/details/79483793