poj 1840 Eqs (hash)

Eqs

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.
Input
The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output
The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47
Sample Output
654

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAXN=25000010;

short hash[MAXN];
int a1,a2,a3,a4,a5;
int ans,temp;

int main()
{
    while(scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5)!=EOF)
    {
        ans=0;
        memset(hash,0,sizeof(hash));
        for(int i=-50;i<=50;i++)
            for(int j=-50;j<=50;j++)
            {
                if(i==0||j==0) continue;
                temp=(a1*i*i*i+a2*j*j*j)*(-1);
                if(temp<0) temp+=MAXN;
                hash[temp]++;
            }
        for(int i=-50;i<=50;i++)
            for(int j=-50;j<=50;j++)
                for(int k=-50;k<=50;k++)
                {
                    if(i==0||j==0||k==0) continue;
                    temp=a3*i*i*i+a4*j*j*j+a5*k*k*k;
                    if(temp<0) temp+=MAXN;
                    if(hash[temp]) ans+=hash[temp];
                }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/wanghaixv/p/9032572.html
今日推荐