POJ3274(数的哈希)

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list of only Kdifferent features (1 ≤ K ≤ 30). For example, cows exhibiting feature #1 might have spots, cows exhibiting feature #2 might prefer C to Pascal, and so on.

FJ has even devised a concise way to describe each cow in terms of its "feature ID", a single K-bit integer whose binary representation tells us the set of features exhibited by the cow. As an example, suppose a cow has feature ID = 13. Since 13 written in binary is 1101, this means our cow exhibits features 1, 3, and 4 (reading right to left), but not feature 2. More generally, we find a 1 in the 2^(i-1) place if a cow exhibits feature i.

Always the sensitive fellow, FJ lined up cows 1..N in a long row and noticed that certain ranges of cows are somewhat "balanced" in terms of the features the exhibit. A contiguous range of cows i..j is balanced if each of the K possible features is exhibited by the same number of cows in the range. FJ is curious as to the size of the largest balanced range of cows. See if you can determine it.

Input
Line 1: Two space-separated integers,  N and  K
Lines 2..  N+1: Line  i+1 contains a single  K-bit integer specifying the features present in cow  i. The least-significant bit of this integer is 1 if the cow exhibits feature #1, and the most-significant bit is 1 if the cow exhibits feature #  K.
Output
Line 1: A single integer giving the size of the largest contiguous balanced group of cows.
Sample Input
7 3
7
6
7
2
1
4
2
Sample Output
4
Hint

In the range from cow #3 to cow #6 (of size 4), each feature appears in exactly 2 cows in this range

题意:输入n,k,接下来给你n个数,每个数的二进制不超过k位,求最大的区间[L,R]满足k位二进制和都相同的区间长度。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 100010
#define Mod 100007
int a[N][32];
int n,m,ans;
int head[N],tot;
struct node
{
    int v,next;
}e[N];
int cmp(int x1,int x2)
{
    int i;
    for(i=0;i<m;i++)
    if(a[x1][i]!=a[x2][i])
    return 0;
    return 1;
}
int cmp1(int x)
{
    int i;
    for(i=1;i<m;i++)
    if(a[x][i]!=a[x][i-1])
    return 0;
    return 1;
}
int get(int x)
{
    int s=0,i;
    for(i=0;i<m;i++)
        s=s+a[x][i]*(i+1);
    return (s+Mod)%Mod;
}
void find(int s)
{
    int x=get(s);
    int ne=head[x];
    while(ne!=-1)
    {
        if(cmp(e[ne].v,s))
        {
            if(s-e[ne].v>ans)
                ans=s-e[ne].v;
            return;
        }
        ne=e[ne].next;
    }
    e[tot].v=s;
    e[tot].next=head[x];
    head[x]=tot++;
}
int main()
{
    int i,j,k,x;
    scanf("%d%d",&n,&m);
    memset(head,-1,sizeof(head));
    ans=0;
    tot=0;
    for(i=0;i<n;i++)
    {
        scanf("%d",&x);
        for(j=0;j<m;j++)
        {
            a[i][j]=x%2;
            x=x/2;
        }
    }
    for(i=1;i<n;i++)
    for(j=0;j<m;j++)
    a[i][j]=a[i][j]+a[i-1][j];
    for(i=n-1;i>=0;i--)
    if(cmp1(i))
    {
        ans=i+1;
        break;
    }
    for(i=0;i<n;i++)
    for(j=0;j<m;j++)
    a[i][j]=a[i][j]-a[i][m-1];
    for(i=0;i<n;i++)
        find(i);
    printf("%d\n",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37751662/article/details/79438809