POJ1840哈希

Description

Consider equations having the following form:
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

补充:

~是按位取反

scanf的返回值是输入值的个数

如果没有输入值就是返回-1

-1按位取反结果是0

while(~scanf("%d", &n))就是当没有输入的时候退出循环

题目链接:http://poj.org/problem?id=1840

#include<stdio.h>
#include<string.h>
short ahash[25000005];
int main()
{
    int a1,a2,a3,a4,a5,x1,x2,x3,x4,x5,sum,cnt;
    while(~scanf("%d%d%d%d%d",&a1,&a2,&a3,&a4,&a5))//没有~会超时
    {
        memset(ahash,0,sizeof(ahash));
        for(x1=-50;x1<=50;x1++)
        {
            if(!x1)
                continue;//x不为0
            for(x2=-50;x2<=50;x2++)
            {
                if(!x2)
                    continue;
                sum=-1*(a1*x1*x1*x1+a2*x2*x2*x2);
                if(sum<0)
                    sum+=25000000;
                ahash[sum]++;
            }
        }
        cnt=0;
        for(x3=-50;x3<=50;x3++)
        {
            if(!x3)
                continue;
            for(x4=-50;x4<=50;x4++)
            {
                if(!x4)
                    continue;
                for(x5=-50;x5<=50;x5++)
                {
                    if(!x5)
                        continue;
                    sum=a3*x3*x3*x3+a4*x4*x4*x4+a5*x5*x5*x5;
                    if(sum<0)
                        sum+=25000000;
                    cnt+=ahash[sum];
                }
            }
        }
        printf("%d\n",cnt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/salmonwilliam/article/details/81194426