poj 2096(概率dp)

Collecting Bugs

Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 7496   Accepted: 3564
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output 

3.0000

// dp[i][j] 表示 从在j个子系统中已发现i个bug到 s个系统中发现n个bug 需要的期望天数 

 dp[i][j] 可转化为4种状态

dp[i+1][j+1]  //在新的一个子系统中发现新的bug

                      p1 = (n - i) / n * (s - j) / s    (为什么 == 这个:  p1代表从dp[i][j]状态到dp[i+1][j+1]状态 发生的概率 )

dp[i][j+1]      //在新的子系统中未发现新的bug

                      p2 = i / n * (s - j) / s

dp[i+1][j]      //在之前检查过的子系统中发现新的bug

                     p3 = (n - i) / n * j / s

dp[i][j]         //在之前检查过的子系统中发现已经发现的bug

                     p4 = i / n * j / s;

dp[i][j] = dp[i+1][j+1] * p1 + dp[i][j+1] * p2 + dp[i+1][j] * p3 + dp[i][j] * p4 + 1;    // + 1 是因为时间推移 , + 1 天

注意 递推式不能够含有相同的项,需先合并同类项

#include<cstdio>
#include<cstring>
double dp[1100][1100];  
                        //dp[i][j] 相较于 dp[i+1][j+1] 等 可理解为 需要待发现的  bug 与 子系统更多
int main()              //显然, dp[i][j] 到 s个系统中发现n个bug 需要的期望天数的条件比 dp[i+1][j+1],dp[i][j+1] 等 更加
{                       //不容易一些,  故很好理解到 ,dp[i][j] 的期望 由 dp[i+1][j+1] 等所求的
    int n,s;            //对随机变量A、B,有 数学期望E(aA+bB)=aE(A)+bE(b);
    while(~scanf("%d%d",&n,&s)){
        memset(dp,0,sizeof(dp));
        for(int i = n;i >= 0;i --){
            for(int j = s;j >= 0;j --){
                if(i == n && j == s) continue;
                dp[i][j]=((dp[i+1][j+1]*(n-i)*(s-j)+dp[i][j+1]*i*(s-j)+dp[i+1][j]*(n-i)*j)/(1.0*n*s)+1)/(1-(1.0*i*j/n/s));
            }
        }
        printf("%.4lf\n",dp[0][0]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/no_o_ac/article/details/81160054