Collecting Bugs (POJ-2096) 纯期望DP

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program.
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category.
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version.
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem.
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

题意:给你n种bug和s个系统,需要你在每一个系统中都找到一个bug,问你所需时间的期望。

思路:我们设dp[i][j],表示找到i个bug,并且存在在j个子系统中,要达到目标状态的天数的期望。
显然,dp[n][s]=0,因为已经达到目标了。而dp[0][0]就是我们要求的答案。

根据题意,每个dp[i][j] 之后可以达到的状态有四种。
于是我们能得到这样一个递推式:
dp[i][j]=(((n-i) * j * dp[i+1][j] + i * (s-j) * dp[i][j+1] + (n-i) * (s-j) * dp[i+1][j+1] + n * s)) / ((n*s - i * j));
然后就根据这个式子从后往前推即可得到答案。
AC代码:

#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
#include<iomanip>
const int maxn=1010;
const int inf=0x3f3f3f3f;
using namespace std;
double dp[maxn][maxn];
int main()
{
	int n,s;
	cin>>n>>s;
	memset(dp,0,sizeof(dp));
	dp[n][s]=0;
	for(int i=n;i>=0;i--)
	{
		for(int j=s;j>=0;j--)
		{
			if(i==n && j==s)
                continue;
			dp[i][j]=(((n-i)*j*dp[i+1][j]+i*(s-j)*dp[i][j+1]+(n-i)*(s-j)*dp[i+1][j+1]+n*s)*(1.0))/((n*s-i*j)*(1.0));
		}
	}
	cout<<fixed<<setprecision(4)<<dp[0][0]<<endl;
	return 0;
}
发布了204 篇原创文章 · 获赞 16 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/weixin_43846139/article/details/104027504
今日推荐