A * B Problem Plus HDU - 1402 (快速傅里叶变换)

Calculate A * B.
Input
Each line will contain two integers A and B. Process to end of file.

Note: the length of each integer will not exceed 50000.
Output
For each case, output A * B in one line.
Sample Input
1
2
1000
2
Sample Output
2
2000
一个FFT的板子题吧。就是大数的高精度的乘法。
终于学完了FFT的理论知识了,我觉得学FFT最好还是看算法导论,讲的还是很清楚的,但是即使清楚了原理,如果要写出来还是很难的。。。
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<cmath>
#include<algorithm>
#include<queue>
using namespace std;
const double PI=acos(-1.0);
struct Complex
{
    double x,y;
    Complex(double _x=0.0,double _y=0.0)
    {
        x=_x;
        y=_y;
    }
    Complex operator-(const Complex &b)const
    {
        return Complex(x-b.x,y-b.y);
    }
    Complex operator+(const Complex &b)const
    {
        return Complex(x+b.x,y+b.y);
    }
    Complex operator*(const Complex &b)const
    {
        return Complex(x*b.x-y*b.y,x*b.y+y*b.x);
    }
};//复数定义
void change(Complex y[],int len)//len必须是2的幂次
{
    int i,j,k;
    for(i=1,j=len>>1;i<len-1;i++)
    {
        if(i<j)swap(y[i],y[j]);
        k=len>>1;
        while(j>=k)
        {
            j-=k;
            k/=2;
        }
        if(j<k)j+=k;
    }
}//做dft需要的对换,dft的另一种方式是递归,但是常数很大,替代递归就是迭代了,迭代需要对换。
void fft(Complex y[],int len,int on)//len必须是2的幂次
{
    change(y,len);
    for(int h=2;h<=len;h<<=1)
    {
        Complex wn(cos(-on*2*PI/h),sin(-on*2*PI/h));
        for(int j=0;j<len;j+=h)
        {
            Complex w(1,0);
            for(int k=j;k<j+h/2;k++)
            {
                Complex u=y[k];
                Complex t=w*y[k+h/2];
                y[k]=u+t;
                y[k+h/2]=u-t;
                w=w*wn;
            }
        }
    }
    if(on==-1)
        for(int i=0;i<len;i++)
            y[i].x/=len;
}//on为1时是把系数表示转化为点值表示即DFT,为-1时即逆DFT,还原为系数表示
const int maxx=200010;
Complex x1[maxx],x2[maxx];
char str1[maxx/2],str2[maxx/2];
int sum[maxx];
int main()
{
    while(scanf("%s%s",str1,str2)==2)
    {
        int len1=strlen(str1);
        int len2=strlen(str2);
        int len=1;
        while(len<len1*2||len<len2*2)len<<=1;//把len填充到2的幂次
        for(int i=0;i<len1;i++)
            x1[i]=Complex(str1[len1-1-i]-'0',0);
        for(int i=len1;i<len;i++)
            x1[i]=Complex(0,0);//补位填零
        for(int i=0;i<len2;i++)
            x2[i]=Complex(str2[len2-1-i]-'0',0);
        for(int i=len2;i<len;i++)
            x2[i]=Complex(0,0);//补位填零
        fft(x1,len,1);//转化为点值
        fft(x2,len,1);//转化为点值
        for(int i=0;i<len;i++)
            x1[i]=x1[i]*x2[i];
        fft(x1,len,-1);//转化为系数
        for(int i=0;i<len;i++)
            sum[i]=(int)(x1[i].x+0.5);//补精度
        for(int i=0;i<len;i++)
            sum[i+1]+=sum[i]/10,sum[i]%=10;//进位
        len=len1+len2-1;
        while(sum[len]<=0&&len>0)len--;
        for(int i=len;i>=0;i--)
            printf("%d",sum[i]);
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/coldfresh/article/details/81134379