poj 3259 Wormholes(判断图中是不是存在负环)

                                                                                   Wormholes
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 59278   Accepted: 22160

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
//题意:给你n个区域,有m条双向路把这n个区域连起来,其中还有w个单向的虫洞可以当路来用(这样就有2*m+w条路);
//接下来的m行输入这m条路,每条路由起点s,终点e,话费时间t构成;
//再接下来的w行表示w个虫洞,每个虫洞由起点s,终点e,以及从s到e可以让你的时间回退多少(就是这条边的权值是负的,它是用来减时间的);
//这样题目就来了,问你他走着走着是否可以回到起始时间之前,就是问你图中是否存在负环.
//这不就很简单了吗? 
#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<vector>
#include<cmath>
#define maxn1 505
#define maxn2 5400
#define INF 0x3f3f3f3f
using namespace std;
int n, m, w; //n个field,m条双向道路,w条单向虫洞;
struct edge{
    int from, to, cost;
}G[maxn2];
int dis[maxn1];
int len;
bool find_negative_loop(){
    memset(dis, 0, sizeof(dis));

    for(int i = 0; i < n; i++){
        for(int j = 0; j < len; j++){
            edge e = G[j];
            if(dis[e.to] > dis[e.from]+e.cost){
                dis[e.to] = dis[e.from]+e.cost;

                if(i == n-1)      //如果从第0到第n-1总共n次都更新了,说明存在负环(不存在负环的图,第一层for循环最多进行n-1次)
                    return true;
            }
        }
    }
    return false;
}
int main(){
    int s, e, v;
    int f;
    cin >> f;
    while(f--){
        scanf("%d%d%d", &n, &m, &w);
        len = 0;
        for(int i = 0; i < m; i++){   //道路是双向的
            scanf("%d%d%d", &s, &e, &v);
            G[len].from = s;
            G[len].to = e;
            G[len].cost = v;
            len++;
            G[len].from = e;
            G[len].to = s;
            G[len].cost = v;
            len++;
        }
        for(int j = 0; j < w; j++){  //虫洞是单向的
            scanf("%d%d%d", &s, &e, &v);
            G[len].from = s;
            G[len].to = e;
            G[len].cost = -v;
            len++;
        }
        if(find_negative_loop()){
            printf("YES\n");
        }
        else
            printf("NO\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guihaiyuan123/article/details/80151887
今日推荐