暑期算法心得-----图的遍历(DFS)

1034 Head of a Gang (30)(30 分)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threshold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threshold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

 解答(心得见代码)

#include <cstdio>
#include <map>
#include <iostream>

using namespace std;

map<int,string> int2str;
map<string,int> str2int;
map<string,int> cluster;
int N,K;
int numpoint=0;
const int maxn=2001;

int G[maxn][maxn]={0};
int weight[maxn]={0};
bool visit[maxn]={false};

void DFS(int u,int& head,int& member,int& tot)
{
    int v;
    member++;
    visit[u]=true; //每次递归开始的时候,一定要记得对当前访问的元素做上访问标记
    if(weight[head]<weight[u])
        head=u;
    for(int v=0;v<numpoint;v++)
    {
        if(G[u][v]>0)
        {
                tot+=G[u][v]; //先进行边权的累加
                G[u][v]=G[v][u]=0;//防止重复访问,此处是一个比较好的技巧,可以根据题目条件进行灵活处理
                if(visit[v]==false) //对于已经访问过的元素,此处不宜再做处理
                    DFS(v,head,member,tot);
        }
    }
}

void DFSTraverse()
{
    int u;
    for(u=0;u<numpoint;u++)
    {
        if(visit[u]==false)
        {
            int head=u; //设置每个cluster的初始head为起点元素
            int member=0;
            int tot=0;
            DFS(u,head,member,tot);
            if(member>2&&tot>K)
            {
                cluster[int2str[head]]=member;
            }
        }
    }
}

int change(string str)
{
    if(str2int.find(str)!=str2int.end()) //通过map映射的特点间接地记录总人数
    {
        return str2int[str];
    }
    else
    {
        str2int[str]=numpoint;
        int2str[numpoint]=str;
        return numpoint++;
    }
}

int main()
{
    cin>>N>>K;
    int i,j,k,time;
    string str1,str2;
    for(int i=0;i<N;i++)
    {
        cin>>str1>>str2>>time;
        int person1=change(str1);
        int person2=change(str2);
        G[person1][person2]+=time; //尽量在初始化的过程中完成权重的处理
        G[person2][person1]+=time;//如果图中寄存在环,有存在单向边,可以根据题意确定是否可以将图转换为无向图进行处理
        weight[person1]+=time;
        weight[person2]+=time;
    }
    DFSTraverse();
    cout<<cluster.size()<<endl;
    map<string,int>::iterator it;
    for(it=cluster.begin();it!=cluster.end();it++)
    {
        cout<<it->first<<" "<<it->second<<endl;
    }
    return 0;

}

猜你喜欢

转载自blog.csdn.net/chengsilin666/article/details/81171428