Maximum Subsequence Sum(java)

7-1 Maximum Subsequence Sum(25 分)

Given a sequence of K integers { N1N2, ..., NK }. A continuous subsequence is defined to be { NiNi+1, ..., Nj } where 1ijK. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

思路:

1、在线处理,就是每输入一个数据就进行即时处理,实时获得当前最优解。看程序注释。

2、当数据量最大时,会出现内存超限,感觉和语言有关,c怎么不超限,就java超限。



import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		int k = in.nextInt();
		
		int tp=-1;
		int sum = 0;
		int max = 0;
		int count=0;
		int start = -1,end = 0;

		int p = Integer.MAX_VALUE ;
		int a[] =new int [k];
		for(int i = 0 ; i < k; i++) 
		{
			a[i]=in.nextInt();
			if(a[i]==0)
				{
					count=1;
					if(i<p)
						p = i; 							//既有负数又有0的情况
				}                                  
			if (a[i]>=0) 
			{
				sum+=a[i];
				if(tp<0) 								//小于0才更新,等于0都不用更新,因为取得是最小的i
				{
					tp = a[i];							//更新左边的值
				}
			}
			else if(sum+a[i]<0)
					{
						sum=0;
						tp=-1;                          //在线处理,舍弃之前的结果
					}
					
			     else 
			    	 sum+=a[i];
			 if(sum>max)								//记录当前最大子数列
			 {
	    		 max=sum;
	    		 end=a[i];
	    		 start=tp;
			 }

			 
		}
		if (max==0&&count==0)							//全是负数的情况
		{
			start = a[0];
			end = a[k-1];
		}
		if(max==0&&count==1) 							//全是0的情况
		{
			start = a[p];
			end = start;
		}
		
		System.out.print(max+" "+start+" "+end);
		System.out.print(max);

	}  
	
		

}

猜你喜欢

转载自blog.csdn.net/weixin_38902950/article/details/80648257