Work(简单并查集)

Work

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)

Total Submission(s) : 6   Accepted Submission(s) : 2

Problem Description



It’s an interesting experience to move from ICPC to work, end my college life and start a brand new journey in company.
As is known to all, every stuff in a company has a title, everyone except the boss has a direct leader, and all the relationship forms a tree. If A’s title is higher than B(A is the direct or indirect leader of B), we call it A manages B.
Now, give you the relation of a company, can you calculate how many people manage k people.

Input

There are multiple test cases. Each test case begins with two integers n and k, n indicates the number of stuff of the company. Each of the following n-1 lines has two integers A and B, means A is the direct leader of B. 1 <= n <= 100 , 0 <= k < n 1 <= A, B <= n

Output

For each test case, output the answer as described above.

Sample Input

 

7 2 1 2 1 3 2 4 2 5 3 6 3 7

Sample Output

 

2

Author

ZSTU

终于有道水题了~~~~~

思路:简单并查集的应用

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=130;
int fa[maxn];
int num[maxn];
int finda(int a)
{
    while(fa[a]!=a)
    {
        a=fa[a];
        ++num[a];
    }
}
int main()
{
    int n;
    int k;
    int ans;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        memset(num,0,sizeof(num));
        ans=0;
        for(int i=1;i<=n;i++)
        {
            fa[i]=i;
        }
        int a,b;
        for(int i=1;i<=n-1;i++)
        {
            scanf("%d%d",&a,&b);
            fa[b]=a;
        }
        for(int i=1;i<=n;i++)
        {
            finda(i);
        }
        for(int i=1;i<=n;i++)
        {
            if(num[i]==k)
                ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/81137283
今日推荐