The Suspects (简单并查集)

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

这道题就是要求你找出可能的感染人,我开始把这道题想复杂了,其实,只要每次输入一组的时候,把哪一组的链接起来,这样就简单了很多

#include<iostream>
using namespace std;
int pre[30005];
int find(int x){
	if(pre[x]==x)
	    return pre[x];
	else
	    return pre[x]=find(pre[x]);
}
void merge(int x,int y){
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
	}
}
int main(){
	int n,m;
	while(~scanf("%d%d",&n,&m)){
		if(n==0&&m==0)
		    break;
		for(int i=0;i<n;i++){
			pre[i]=i;
		}
		for(int i=0;i<m;i++)
		{
			int k,x,o;
			scanf("%d",&k);
			scanf("%d",&x);
			for(int j=1;j<k;j++){
				scanf("%d",&o);
				merge(x,o);
			}
		}
		int sum=0;
		for(int i=0;i<n;i++){
			if(find(i)==find(0))
			    sum++;
		}
		cout<<sum<<endl;
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/red_red_red/article/details/86925157
今日推荐