POJ-3263 Tallest Cow

Tallest Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 5425   Accepted: 2500

Description

FJ's N (1 ≤ N ≤ 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 ≤ H ≤ 1,000,000) of the tallest cow along with the index I of that cow.

FJ has made a list of R (0 ≤ R ≤ 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17.

For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

Input

Line 1: Four space-separated integers: N, I, H and R
Lines 2.. R+1: Two distinct space-separated integers A and B (1 ≤ A, BN), indicating that cow A can see cow B.

Output

Lines 1.. N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8

Sample Output

5
4
5
3
4
4
5
5
5

Source

OJ-ID:
poj-3263

author:
Caution_X

date of submission:
20191117

tags:
差分,前缀和

description modelling:
有n头牛排成一列,已知最高的牛的高度H和标号以及R个关系
关系:xi和yi两头牛可以相互看见,即xi和yi牛之间的牛都比他们矮
输出每一头牛的最大高度

major steps to solve it:
(1)用数组标记每一对xi和yi,a[xi+1]+=-1,a[yi]+=1
(2)用tmp存储当前的前缀和,当前牛的最大高度=H+tmp

AC code:

#include<cstdio>
#include<cmath>
#include<algorithm>
#include<set>
using namespace std;
typedef pair<int,int> P;
set<P> book;
int a[10005];
int main()
{
    //freopen("input.txt","r",stdin);
    int N,I,H,R;
    scanf("%d%d%d%d",&N,&I,&H,&R);
    for(int i=0;i<R;i++)
    {
        int x,y;
        scanf("%d%d",&x,&y);
        int temp=min(x,y);
        y=max(x,y);
        x=temp;
        P tmp=P(x,y);
        if(book.find(tmp)==book.end()&&abs(x-y)>1)
        {
            a[x+1]--;
            a[y]++;
            book.insert(tmp);
        }
    }
    int tmp=0;
    for(int i=1;i<=N;i++)
    {    
        tmp+=a[i];
        //cout<<tmp<<' ';
        printf("%d\n",tmp+H);
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/cautx/p/11879134.html