oj 多项式求和


多项式求和

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

多项式描述如下:
1 - 1/2 + 1/3 - 1/4 + 1/5 - 1/6 ……
先请你求出多项式前n项的和。

Input

第一行输入一个数T代表测试数据个数(T<=1000)。接下来T行每行1个数代表n(0<=n< 2^31)。
 

Output

 对于每个输入样例,输出多项式和的结果(结果精确到小数点后两位)。每行输出一个结果。

Sample Input

2
1
2

Sample Output

1.00
0.50 

Hint

 

Source

中国海洋大学第三届“朗讯杯”编程比赛高级组试题

#include <stdio.h>
#include <stdlib.h>

int main()
{int n,m,i,t;
double s;
scanf("%d",&m);
while(m--)
{
    scanf("%d",&n);
    s=0;
    t=1;
    for(i=1;i<=n;i++)
    {if(i>150)break;//大于155时,他的值都为零 也就是0.00啦
      s+=t*(1.0/i);
      t=-t;



    }
    printf("%.2lf\n",s);
}

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41374539/article/details/81066087