多项式求和 SDUT25044

多项式求和

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

多项式描述如下:

1 - 1/2 + 1/3 - 1/4 + 1/5 - 1/6 ……

先请你求出多项式前n项的和。

Input

第一行输入一个数T代表测试数据个数(T<=1000)。接下来T行每行1个数代表n(0<=n< 2^31)。

Output

 对于每个输入样例,输出多项式和的结果(结果精确到小数点后两位)。每行输出一个结果。

Sample Input

2
1
2

Sample Output

1.00
0.50 

Hint

 这道题,做的很肝疼,1000以后就不用考虑了

Source

中国海洋大学第三届“朗讯杯”编程比赛高级组试题

#include <stdio.h>

int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        double sum=0;
        int sign=1;
        for(int i=1;i<=n;i++)
        {
            if(i>1000) break;
            sum+=sign*1.0/i;
            sign=-sign;
        }
        printf("%.2lf\n",sum);
    }
    return 0;
}

/***************************************************
Result: Accepted
Take time: 0ms
Take Memory: 144KB
Submit time: 2018-08-01 16:56:31
****************************************************/

猜你喜欢

转载自blog.csdn.net/Allinone99/article/details/81333979