K - Curling 2.0寒假练习2-K

来源:POJ - 3009
On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.

Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

Fig. 3: The solution for Fig. D-1 and the final board configuration

Input
The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output
For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1
题意概括:给你一张地图,2是起点,3是终点,标号为0的可以走,标号为1的遇见后会转向反转,翻转后标号为1的障碍物也可以走了,求从2到3的最小转向次数,如果不能到达就输出-1。
解题思路:深搜遍历,遍历当前障碍结点时把障碍点消掉,向下搜回来之后再置为障碍点。
代码:

#include<stdio.h>
#include<string.h> 
#define MAX 99999999
int next[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int ex,ey,sx,sy;
int map[25][25];
int w,h,min;

void dfs(int x,int y,int s)
{
//  printf("!%d %d\n",s,min);
    if(s>=10) return ;
    int i;
    for(i=0;i<4;i++)
    {       
        int tx=x;
        int ty=y;
        while(1)//沿着当前方向搜下去 
        {
            tx+=next[i][0];
            ty+=next[i][1];
//          printf("!!!i=%d %d %d\n",i,tx,ty);
            if(tx<=0||tx>h||ty<=0||ty>w) break;
//          printf("%d %d %d\n",i,tx,ty);
//          printf("")
            if(map[tx][ty]==3) 
            {
                s++;
                if(min>s) min=s;//printf("~~%d %d\n",s,min);
                s--;
                return;
            }
            else if(map[tx][ty]==1)
            {
//              printf("~~~%d %d\n",tx-next[i][0],ty-next[i][1]);

                if(tx-next[i][0]!=x||ty-next[i][1]!=y)
                {
                    map[tx][ty]=0;//清除当前障碍物 

                    dfs(tx-next[i][0],ty-next[i][1],s+1);
                    map[tx][ty]=1;//搜索后恢复障碍物 
                }//printf("!!\n");
                break;
            }
        }
    }
}       
int main()
{
    while(scanf("%d%d",&w,&h),w||h)
    {
        for(int i=1;i<=h;i++)
            for(int j=1;j<=w;j++)
            {
                scanf("%d",&map[i][j]);
                if(map[i][j]==2)
                    sx=i,sy=j;
                else if(map[i][j]==3)
                    ex=i,ey=j;
            }
            min=MAX;
//          printf("!!!%d %d %d %d\n",ex,ey,sx,sy);
            dfs(sx,sy,0);
            if(min==MAX) 
            printf("-1\n");
            else printf("%d\n",min);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/watestill/article/details/79250886
k
今日推荐