Curling 2.0 POJ - 3009

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1


题意概括:一个游戏类似冰壶,每次可以选择前后左右三个方向移动,如果没用撞到墙它会移动到出界为止(出界视为无法到达终点),遇到墙后球停止,然后被撞到的墙会消失,问球能否从2的位置移动到3。如果不能输出-1(次数大于10次视为不能到达),能输出最少的移动次数。

解题思路:把题翻译完之后,想到的就是搜索,然后就开始用深搜开始写,首先需要确定4个移动方向,然后对于每个方向看是否能找到墙使球停下来,不然就出界了,对于每次球停的位置,可以先判断一下球是否能直接到达终点(球和终点在一条直线上且中间没用墙也就是说再移动一次即可到达终点)。对于出界的球开始是打算单独判断一下的,但是这样不但麻烦还不好实现,最后发现不用单独判断,出界的情况不会进入新的递归。


代码:

#include<stdio.h>
#include<string.h> 
#define N 50
int map[N][N];
int m,n,sum,min;
int Gx,Gy;
int IsG(int x,int y)//判断是否已经到达终点或者再移动一步即可到达终点
{
	int i;
	if(map[x][y]==3)
		return 1;
	if(x==Gx)
	{
		if(y>Gy)
		{
			for(i=Gy;i<=y;i++)
			{
				if(map[x][i]==1)
					break;				
			}
			if(i==y+1)
				return 2;
		}
		else
		{
			for(i=y;i<=Gy;i++)
			{
				if(map[x][i]==1)
					break;	
			}
			if(i==Gy+1)
				return 2;
		}
	}
	if(y==Gy)
	{
		if(x>Gx)
		{
			for(i=Gx;i<=x;i++)
			{
				if(map[i][y]==1)
					break;
			}
			if(i==x+1)
				return 2;
		}
		else
		{
			for(i=x;i<=Gx;i++)
			{
				if(map[i][y]==1)
					break;
			}
			if(i==Gx+1)
				return 2;
		}
	}
	return -1;
}
void DFS(int x,int y)
{
	
	int i,j;

	if(sum<=10)//规则要求步数不能大于10
	{
	
	//printf("%d %d %d  IsG==%d\n",x-1,y-1,sum,IsG(x,y));	
	if(IsG(x,y)==1)
	{
		if(min>sum)
			min=sum;	
	}	
	else 
	if(IsG(x,y)==2)
	{
		if(sum+1<min)
			min=sum+1;
	}
	else
	{
		for(j=x;j>=1;j--)//向前
		{
			if(map[j][y]==1)
			{				
				break;	
			}
		}
		if(j>=1&&j!=x-1)
		{	
			map[j][y]=0;
			sum++;					
			DFS(j+1,y);
			sum--;
			map[j][y]=1;
		}
	 	for(j=x;j<=m;j++) //向后
	 	{	 		
	 		if(map[j][y]==1)
	 		{				 	
				break;	
			}
		}
		 if(j<=m&&j!=x+1)
		 {		
			map[j][y]=0;
			sum++;
			DFS(j-1,y);	
			sum--;
			map[j][y]=1;
		 }
	
		for(j=y;j>=1;j--)//向左
		{		
			if(map[x][j]==1)
			{				
				break;			
			}
		}
		if(j>=1&&j!=y-1)
		{	
			map[x][j]=0;
			sum++;
			DFS(x,j+1);	
			sum--;
			map[x][j]=1;
		}	
		for(j=y;j<=n;j++)//向右
		{	
			if(map[x][j]==1)
			{
				break;								
			}		
		}
		if(j<=n&&j!=y+1)
		{
			
			map[x][j]=0;
			sum++;				
			DFS(x,j-1);	
			sum--;
			map[x][j]=1;
		}
	} 
	}
}
int main()
{
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		if(m==0&&n==0)
			break;
		for(i=0;i<=m+1;i++)
		{
			for(j=0;j<=n+1;j++)
			{
				map[i][j]=0;
			}
		} 
		for(i=1;i<=m;i++)
		{
			for(j=1;j<=n;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]==3)
				{
					Gx=i;
					Gy=j;
				}
			}
		}
	
		sum=0;
		min=9999;
		for(i=1;i<=m;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(map[i][j]==2)
				{
					DFS(i,j);
				}
			}
		}
		//printf("%d\n",min);
		if(min>10)
		{
			printf("-1\n");
		}
		else
		{
			printf("%d\n",min);
		}
		
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/gakki_wpt/article/details/79235627