Curling 2.0 POJ - 3009(DFS)

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.
在这里插入图片描述

Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), ©).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
在这里插入图片描述
Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).
在这里插入图片描述

Fig. 3: The solution for Fig. D-1 and the final board configuration

Input
The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

扫描二维码关注公众号,回复: 10333619 查看本文章

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output
For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output
1
4
-1
4
10
-1
思路:太沙雕的一道题目了,同时证明了自己读题不认真。先读入的是列,后读入的是行。然后就按照题意去dfs就可以了。poj真的无语了,有的代码c++可以过但是g++过不了,所以还是多试试吧。
代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=21;
int a[maxx][maxx];
int vis[maxx][maxx];
int d[][2]={{1,0},{0,1},{-1,0},{0,-1}};
int n,m,sx,sy,ex,ey;

inline void dfs(int x,int y,int num,int dir,int &_min)
{
	if(num>10) return ;
	if(x==ex&&y==ey)
	{
		_min=min(_min,num);
		return ;
	}
	if(dir==-1)
	{
		for(int i=0;i<4;i++)
		{
			int tx=x+d[i][0];
			int ty=y+d[i][1];
			if(tx<1||tx>n||ty<1||ty>m||a[tx][ty]==1) continue;
			dfs(tx,ty,num+1,i,_min);
		}
	}
	else if(dir!=-1&&a[x][y]==1)
	{
		a[x][y]=0;
		int zx,zy;
		if(dir==0) zx=x-1,zy=y;
		else if(dir==1) zx=x,zy=y-1;
		else if(dir==2) zx=x+1,zy=y;
		else zx=x,zy=y+1;
		for(int i=0;i<4;i++)
		{
			int tx=zx+d[i][0];
			int ty=zy+d[i][1];
			if(tx<1||tx>n||ty<1||ty>m||a[tx][ty]==1) continue;
			dfs(tx,ty,num+1,i,_min);
		}
		a[x][y]=1;
	}
	else if(dir!=-1)
	{
		int tx=x+d[dir][0];
		int ty=y+d[dir][1];
		if(tx<1||tx>n||ty<1||ty>m) return ;
		dfs(tx,ty,num,dir,_min);
	}
}
int main()
{
	while(scanf("%d%d",&m,&n),n||m)
	{
		for(int i=1;i<=n;i++) for(int j=1;j<=m;j++) scanf("%d",&a[i][j]);
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				if(a[i][j]==2) sx=i,sy=j;
				if(a[i][j]==3) ex=i,ey=j;
			}
		}
		int _min=inf;
		dfs(sx,sy,0,-1,_min);
		if(_min==inf) printf("-1\n");
		else printf("%d\n",_min);
	}
	return 0;
}

努力加油a啊,(o)/~

发布了596 篇原创文章 · 获赞 47 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/105205335
今日推荐