POJ-3009,Curling 2.0(DFS)

Description:

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input: 

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board
...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

 Output:

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number. 

Sample Input: 

2 1

3 2

6 6

1 0 0 2 1 0

1 1 0 0 0 0

0 0 0 0 0 3

0 0 0 0 0 0

1 0 0 0 0 1

0 1 1 1 1 1

6 1

1 1 2 1 1 3

6 1

1 0 2 1 1 3 

12 1

2 0 1 1 1 1 1 1 1 1 1 3

13 1

2 0 1 1 1 1 1 1 1 1 1 1 3

0 0 

Sample Output: 

1

4

-1

4

10

-1 

题目大意: 

题目大意就是给出一个w*h的地图,其中0代表空地,1代表障碍物,2代表起点,3代表终点,每次移动可以走多个方格,每次只能向附近一格不是障碍物的方向移动,直到碰到障碍物才停下来,此时障碍物也会随之消失,如果移动到超出方格的界限或者移动步数超过了10则会game over ,如果行动时经过终点3则会win,记下此时移动次数(不是移动的方格数),求最小的移动次数

程序代码: 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 0x3f3f3f
int map[30][30];//地图 
int w,h,minn,sx,sy;
int dir[4][4]={{0,1},{0,-1},{-1,0},{1,0}};//方向数组 
void dfs(int x,int y,int step)
{
	step++;//步数加1 
	if(step>10)//如果步数超过10,结束搜索 
		return ;
	for(int i=0;i<4;i++)
	{
		int tx=x+dir[i][0];
		int ty=y+dir[i][1];
		if(map[tx][ty]==1)//如果是墙,不能向此方向抛石头 
			continue;
		while(map[tx][ty]==0||map[tx][ty]==2)//0是空地,2是出发点,都可以经过 
		{//因为题目说每次可以移动不止一格 
			tx=tx+dir[i][0];//在上一个位置基础上向前扩展搜索 
			ty=ty+dir[i][1];
		}
		if(map[tx][ty]==-1)//如果出界,结束搜索 
			continue;
		if(map[tx][ty]==1)//如果是墙 
		{
			map[tx][ty]=0;//按题意,碰到墙,则墙消失 
			dfs(tx-dir[i][0],ty-dir[i][1],step);//这里要回溯,因为要算最少移动步数,就不要碰到墙 
			map[tx][ty]=1;//再将这个点变为墙 
		}
		if(map[tx][ty]==3)//到达终点3 
		{
			if(step<minn)//更新步数 
				minn=step;
			continue;
		}
	}
}
int main()
{
	while(cin>>w>>h)
	{
		if(w==0&&h==0)
			break;
		minn=INF;
		memset(map,-1,sizeof(map));//地图全部初始化为-1 
		for(int i=1;i<=h;i++)
		{
			for(int j=1;j<=w;j++)
			{
				cin>>map[i][j];
				if(map[i][j]==2)
				{
					sx=i;
					sy=j;
				}
			}
		}
		dfs(sx,sy,0);//起点带入开始搜索 
		if(minn<INF)//能到达终点 
			cout<<minn<<endl;
		else//不能到达 
			cout<<"-1"<<endl;
	}
	return 0;
}
发布了260 篇原创文章 · 获赞 267 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/weixin_43823808/article/details/103796168