【ACM】【DFS】Curling 2.0

版权声明:转载请注明出处~~~ https://blog.csdn.net/lesileqin/article/details/89044718

Curling 2.0

点我前往题目链接

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 28809   Accepted: 11408

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board
...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1

Source

Japan 2006 Domestic

题目大意:

是一个冰球游戏!问:用最少的步骤将球从开始的地方移到终点。
0     vacant square
1     block
2     start position
3     goal position
移动规则:
A、    The stone stops at the square next to the block it hit.The block disappears.
B、    The stone gets out of the board.The game ends in failure.
C、    You cannot throw the stone more than 10 times in a game.
D、    You may throw it to any direction unless it is blocked immediately.

解题思路:

DFS!定义四个方向、遍历每个方向的时候,加一步循环,预判下一步是否到了重点,预判下下步是不是障碍物,如果遇到障碍物、把障碍物销毁、继续深搜;深搜后重建障碍物。

AC代码如下:

/*
Curling 2.0
0 	vacant square
1 	block
2 	start position
3 	goal position
规则 
A、	The stone stops at the square next to the block it hit.The block disappears. 
B、	The stone gets out of the board.The game ends in failure. 
C、	You cannot throw the stone more than 10 times in a game.
D、	You may throw it to any direction unless it is blocked immediately. 
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int Max = 20 + 10;
int map[Max][Max];
int dir[4][2] = {{-1,0},{0,-1},{1,0},{0,1}}; //0上,1左,2下,3右 
int flag; //标记是否找到解
int minStep; 
int w,h;
void dfs(int x, int y, int step)
{
 
	int nx,ny;
	int tx,ty;
	int px,py;
	if(step > 10)
		return;
	if(map[x][y] == 3)
	{
		minStep = min(minStep, step); 
		return;
	}
	for(int i=0; i<4; i++)
	{
		tx = x + dir[i][0];
		ty = y + dir[i][1];
		nx = x;
		ny = y;	 
		while(tx >= 0 && tx < h && ty >= 0 && ty < w && map[tx][ty] != 1) //预判下一步
		{
			nx += dir[i][0];
			ny += dir[i][1];
			if(map[nx][ny] == 3) 
			{
				minStep = min(minStep, step); 
				return;
			}
			tx = nx + dir[i][0];
			ty = ny + dir[i][1];
		 	if(tx < 0 || tx >= h || ty < 0 || ty >= w)
				  break;  
			if(map[tx][ty] == 1) 
			{
				map[tx][ty] = 0; //消除障碍 
				dfs(nx, ny, step+1);
				map[tx][ty] = 1; //重建障碍 
			}
		}
		
	}
}
int main()
{
	int sx,sy;
	while(scanf("%d %d",&w,&h) != EOF && w != 0 && h != 0)
	{
		minStep = 10000;
		for(int i=0; i<h; i++)
		{
			for(int j=0; j<w; j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j] == 2) //起点 
				{
					sx = i;
					sy = j;
				}
			}
		}
		dfs(sx, sy, 1); 
		if(minStep == 10000)
			cout<<"-1"<<endl;
		else
			cout<<minStep<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/lesileqin/article/details/89044718