HDU 1686 KMP + 拓展KMP

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19489    Accepted Submission(s): 7608


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
 
  
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
 
  
1 3 0
 

Source
 

KMP实现 140 ms

注意当找到一个时候 我们要让j=Next[j] 意思是从最长前缀直接跳过去 也就是向右移 减少右移次数

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX_N = 1000024;
int Next[MAX_N];
char mo[MAX_N],str[MAX_N];
int n1,n2,cnt;
void getnext(){
    int i=0,j=-1;
    while(i<n2){
        if(j==-1||mo[i]==mo[j]) {
            ++i;
            ++j;
            Next[i] = j;
        }
        else j = Next[j];
    }
    return ;
}
int kmp(){
    int i=0,j=0;
    while(i<n1){
        if(j==-1||str[i]==mo[j])i++,j++;
        else j=Next[j];
        if(j==n2) {
          j=Next[j];
          cnt++;
    }
    }
    return cnt;
}
int main(){
   int t;
   scanf("%d",&t);
   while(t--){
    cnt = 0;
    memset(str,0,sizeof(str));
    memset(mo,0,sizeof(mo));
    scanf("%s",mo);
    scanf("%s",str);
    n2 = strlen(mo);
    n1=strlen(str);
    Next[0] = -1;
    getnext();
    printf("%d\n",kmp());
   }
   return 0;
}

拓展KMP实现 就不需要注意那个地方了

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int MAX_N = 1000024;
int Next[MAX_N],ex[MAX_N];
char mo[MAX_N],str[MAX_N];
void getnext(char *str){
    int i=0,j,po,len=strlen(str);
    Next[0] = len;
    while(str[i]==str[i+1]&&i+1<len)
    i++;
    Next[1] = i;
    po = 1;
    for(i=2;i<len;++i){
        if(Next[i-po]+i<Next[po]+po)
            Next[i] = Next[i-po];
        else {
        j = Next[po] + po -i;
        if(j<0) j = 0;
        while(i+j<len&&str[j]==str[j+i])
            j++;
        Next[i] = j;
        po = i;
    }
    }
}
void exkmp(char *s1,char *s2){
    int i=0,j,po,len = strlen(s1),l2=strlen(s2);
    getnext(s2);
    while(s1[i]==s2[i]&&i<l2&&i<len)
        i++;
    ex[0] = i;
    po = 0;
    for(i=1;i<len;++i){
        if(Next[i-po]+i<ex[po]+po)
            ex[i] = Next[i-po];
        else {
            j=ex[po]+po-i;
            if(j<0) j = 0;
            while(i+j<len&&j<l2&&s1[j+i]==s2[j])
                j++;
            ex[i]=j;
            po=i;
        }
    }
}
int main(){
   int t;
   scanf("%d",&t);
   while(t--){
    int cnt = 0;
    memset(str,0,sizeof(str));
    memset(mo,0,sizeof(mo));
    scanf("%s",mo);
    scanf("%s",str);
    exkmp(str,mo);
    int len = strlen(str);
    int m = strlen(mo);
    for(int i=0;i<len;i++){
        if(ex[i]==m) cnt++;
    }
    printf("%d\n",cnt);
   }
   return 0;
}

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80806422
今日推荐