POJ.3190.Stall Reservations(优先队列)

Stall Reservations
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10068   Accepted: 3555   Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

Source


考点:优先队列+贪心算法

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;
int per[50010];
struct node
{
    int start,end,pos;
}cow[50010],now;

bool operator < (const node &a,const node &b)//产奶结束越早的越优先
{
	if(a.end==b.end)
		return a.start>b.start;
	return a.end>b.end;
}

int cmp(node a,node b)
{
	if(a.start==b.start)
		return a.end<b.end;
	return a.start<b.start;
}



int main()
{
	int n,i,k,cnt;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=0;i<n;++i){
			scanf("%d%d",&cow[i].start,&cow[i].end);
			cow[i].pos=i;
		}
		sort(cow,cow+n,cmp);
		memset(per,0,sizeof(per));
		priority_queue<node>q;
		q.push(cow[0]);
		per[cow[0].pos]=1;
		k=1;
		for(i=1;i<n;++i)
		{
			now=q.top();
			if(cow[i].start>now.end)//同用一个挤奶机器
			{
				per[cow[i].pos]=per[now.pos];
				q.pop();  //优先删除最早产奶结束
			}
			else//增加一个挤奶机器
				per[cow[i].pos]=++k;
			q.push(cow[i]); //入队时产奶结束最早的优先往前排队
		}
		printf("%d\n",k);
		for(i=0;i<n;++i)
			printf("%d\n",per[i]);
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/xxxxxm1/article/details/80754270