Stall Reservations POJ-3190 解题报告

题目:POJ-2965

http://poj.org/problem?id=3190

Stall Reservations
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9673   Accepted: 3383   Special Judge

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows. 

Help FJ by determining:
  • The minimum number of stalls required in the barn so that each cow can have her private milking period
  • An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 describes cow i's milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have. 

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.

Sample Input

5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample: 

Here's a graphical schedule for this output: 

Time     1  2  3  4  5  6  7  8  9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

Source

解题思路:

贪心算法!!

题目是跟着POJ很好很有层次感做的,在做POJ-1328之前学习了贪心算法,学习过程中做了这道题

基本思路:模拟牛挤奶的顺序,按照结束时间将牛排好序,利用优先队列对栅栏进行判断,随时更新栅栏的结束使用时间,并记录每头牛相应的栅栏号

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

struct Cow  {
	int a,b;
	int No;
	bool operator < (const Cow & c) const {
		return a<c.a;
	}
} cows [50100];
int pos [50100];
struct Stall {
	int end ;
	int No;
	bool operator < (const Stall & s) const {
		return end>s.end;
	}
	Stall (int e ,int n):end(e),No(n){
	}
};

int main ()
{
	int n;
	scanf ("%d",&n);
	for (int i=0;i<n;++i) {
		scanf ("%d%d",&cows[i].a,&cows[i].b);
		cows[i].No=i;
	}
	sort(cows,cows+n);
	int total=0;
	priority_queue<Stall> pq;
	for (int i=0;i<n;++i) {
		if (pq.empty()) {
			++total; 
			pq.push(Stall(cows[i].b,total));
			pos[cows[i].No]=total;
		}
		else {
			Stall st = pq.top();
			if(st.end<cows[i].a) {
				pq.pop();
				pos[cows[i].No]=st.No;
				pq.push(Stall(cows[i].b,st.No));
			}
			else {
				++total;
				pq.push(Stall(cows[i].b,total));
				pos[cows[i].No]=total;
			}
		}
	}
	printf ("%d\n",total);
	for (int i=0;i<n;++i)
		printf("%d\n",pos[i]);
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/sang749992462/article/details/80231103