poj3190 Stall Reservations(堆)

Stall Reservations

Description

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.
Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input

5
1 10
2 4
3 6
5 8
4 7
Sample Output

4
1
2
3
2
4
Hint

Explanation of the sample:

Here’s a graphical schedule for this output:

扫描二维码关注公众号,回复: 2824868 查看本文章

Time 1 2 3 4 5 6 7 8 9 10

Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

题意:N头牛在牛棚挤奶,每个牛棚只能有一头牛,给出每头牛挤奶的开始结束时间,求需要的最小牛棚数和方案。

分析:显然贪心,用堆维护当前最早结束时间,如果第i头牛开始时间大于最早结束时间,那么这头牛可以直接进入此牛棚,否则新开一个牛棚。

代码

#include <cstdio>
#include <queue>
#include <algorithm>
#define N 50005
using namespace std;

struct arr
{
    int x,y,num;
}a[N];
priority_queue<arr> q;
bool operator <(const arr &p, const arr &q)
{
    return p.y > q.y;
}
int n,b[N];

int cmp(arr p, arr q){return p.x < q.x;}

int main()
{
    scanf("%d", &n);
    for (int i = 1; i <= n; i++)
    {
        scanf("%d%d", &a[i].x, &a[i].y);
        a[i].num = i;
    }
    sort(a+1,a+n+1,cmp);
    int cnt = 1;
    b[a[1].num] = cnt;
    q.push(a[1]);
    for (int i = 2; i <= n; i++)
    {
        arr now = q.top();
        if (a[i].x > now.y) 
        {
            b[a[i].num] = b[now.num];
            q.pop();
        }
        else b[a[i].num] = ++cnt;
        q.push(a[i]);
    }
    printf("%d\n", cnt);
    for (int i = 1; i <= n; i++)
        printf("%d\n", b[i]);
}

猜你喜欢

转载自blog.csdn.net/zhanghaoxian1/article/details/81660408