6.3.4 Air Raid

Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 116    Accepted Submission(s): 95

 
Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
Output

            The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
Sample Input
2
4
3
3 4
1 3
2 3
3
3
1 3
1 2
2 3
Sample Output
2
1
 
问题的意思是沿着一条通路一直走到头,再找另外的通路,与原来的通路不相交,问多少条通路能够覆盖所有的顶点。
最小路径覆盖数 = n - 最大匹配数。
 
 
      
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 120 + 5;
const int MAXM = 14400;
int g[MAXN][MAXN], link[MAXN], done[MAXN];	//link表示配对,link[a] = b 表示b->a 这条边已经匹配 
int n, m;


bool find_match(int k){
	for(int i = 1; i <= n; i++){
		if(g[k][i] && !done[i]){
			done[i] = 1;
			if(link[i] == -1 || find_match(link[i])){
				link[i] = k;
				return true;
			}
		}
	}
	return false;
}
int main(){
	int t, a, b, c;
	scanf("%d", &t);
	while(t--){
		memset(g, 0, sizeof(g));
		scanf("%d%d", &n, &m);
		for(int i = 0; i < m; i++){
			scanf("%d%d", &a, &b);
			g[a][b] = 1;
		}
		int cnt = 0;
		memset(link, -1, sizeof(link));
		for(int i = 1; i <= n; i++){
			memset(done, 0, sizeof(done));	//done表示是否已经访问过 
			if(find_match(i)) cnt++;
		}
		printf("%d\n", n - cnt);
	}

	return 1;
}

猜你喜欢

转载自blog.csdn.net/bruce_teng2011/article/details/38560301