Frogger POJ - 2253(可达路径中的最大值)

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:给出青蛙A,B和若干石头的坐标,现青蛙A想到青蛙B那,A可通过任意石头到达B,问从A到B多条路径中的最长边中的最短距离

分析:这题是最短路的变形,以前求的是路径总长的最小值,而此题是通路中最长边的最小值,每条边的权值可以通过坐标算出,因为是单源起点,直接用SPFA算法或dijkstra算法就可以了


#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define Inf 0x3f3f3f3f
using namespace std;
const int N = 205;
double mp[N][N],dis[N];
double x[N],y[N];
int vis[N];
int n;
double getdis(int a,int b){
	double X=(x[a]-x[b]) * (x[a]-x[b]);
	double Y=(y[a]-y[b]) * (y[a]-y[b]);
	return sqrt(X+Y);
}
double SPFA(int s){
	for(int i=0;i<=n;i++){
		dis[i]=Inf;
		vis[i]=0;
	}
	queue<int>p;
	dis[s]=0;
	vis[s]=1;
	p.push(s);
	while(!p.empty()){
		int i=p.front();
		p.pop();
		vis[i]=0;
		for(int j=1;j<=n;j++){
			if(dis[j]>max(dis[i],mp[i][j])){
				dis[j]=max(dis[i],mp[i][j]);
				if(!vis[j]){
					vis[j]=1;
					p.push(j);
				}
			}
		}
	}
	return dis[2];
}
int main(){
	int Cas=0;
	while(scanf("%d",&n)!=EOF&&n){
		memset(mp,0,sizeof(mp));
		for(int i=1;i<=n;i++){
			scanf("%lf%lf",&x[i],&y[i]);
			for(int j=1;j<i;j++)
			   mp[i][j]=mp[j][i]=getdis(i,j);
		}
		printf("Scenario #%d\n",++Cas);
		printf("Frog Distance = %.3f\n",SPFA(1));
		puts("");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/islittlehappy/article/details/80151794