PAT乙级—1054 求平均值 (20分)

本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [−1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y

输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

输入样例 2:
2
aaa -9999
输出样例 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

思路:
  根据实数的性质,编写条件,找到符合实数要求的数

注意:

  1. 首先是小数点后不能超过两位
  2. 只能有一个小数点
  3. -号只能在第一位且只能有一个
  4. 大小只能在[-1000,1000]之间
  5. 经试验,最后一个测试点不通过是因为题目认为123.合法
  6. 算平均数的时候若只有一位数字,则要注意输出字符串的格式

代码:(C++)

#include<iostream>
#include<sstream>
#include<cmath>

using namespace std;

int main()
{
    int n;
    cin>>n;
    int count = n;
    stringstream ss;
    double sum = 0.00;
    for(int i=0; i<n; i++)
    {
        string str;
        int dot=0,sub=0;
        cin>>str;
        bool flag = false;
        for(int j=0; j<str.length(); j++)
        {
            if((str[j]<'0' || str[j]>'9') && str[j]!='.' && str[j]!='-')
            {
                cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
                flag = true;
                break;
            }
            else if(str[j] == '.')
                dot++;
            else if(str[j] == '-')
                sub++;
        }
        if(flag)
        {
            count--;
            continue;
        }
            
        if(dot>1)
        {
            cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
            count--;
            continue;
        }
        if(sub>1 || (sub==1 && str[0]!='-'))
        {
            cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
            count--;
            continue;
        }
        //判断是否只有两位小数
        if(str.find('.') != str.npos) //有小数
        {
            int dd = str.find('.');
            if(str.length()-dd-1>2 || dd==0 ||(str[0]=='-' && dd==1))
            {
                cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
                count--;
                continue;
            }
        }
        double sd;
        
        ss<<str;
        ss>>sd;
        ss.str("");
        ss.clear();
        if(str[0]=='-' && str.length()==2 && floor(sd*100)==0)
        {
            cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
            count--;
            continue;
        }
        if(sd>1000||sd<-1000 ) //此处防止多位0,但可以跟小数点情况
        {
            cout<<"ERROR: "<<str<<" is not a legal number"<<endl;
            count--;
            continue;
        }
        sum+=sd;
    }
    if(count==0)
        cout<<"The average of 0 numbers is Undefined";
    else if(count==1)
        printf("The average of %d number is %.2f",count,sum/count);
    else
        printf("The average of %d numbers is %.2f",count,sum/count);
    
    return 0;
}
发布了77 篇原创文章 · 获赞 20 · 访问量 5770

猜你喜欢

转载自blog.csdn.net/qq_42396168/article/details/105025032