1059 Prime Factors (25 分)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/chen_zan_yu_/article/details/102767178

1059 Prime Factors (25 分)

Given any positive integer N, you are supposed to find all of its prime factors, and write them in the format N = p​1​​​k​1​​​​×p​2​​​k​2​​​​×⋯×p​m​​​k​m​​​​.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range of long int.

Output Specification:

Factor N in the format N = p​1​​^k​1​​*p​2​​^k​2​​**p​m​​^k​m​​, where p​i​​'s are prime factors of N in increasing order, and the exponent k​i​​ is the number of p​i​​ -- hence when there is only one p​i​​, k​i​​ is 1 and must NOT be printed out.

Sample Input:

97532468

Sample Output:

97532468=2^2*11*17*101*1291
#include<bits/stdc++.h>
using namespace std;
const int maxn=100010;
bool is_prime(int n)
{
    if(n<=1)return false;
    int sqr=(int)sqrt(1.0*n);
    for(int i=2; i<=sqr; i++)
    {
        if(n%i==0)return false;
    }
    return true;
}
int prime[maxn],pNum=0;
void Find_prime()
{
    for(int i=1; i<maxn; i++)
    {
        if(is_prime(i)==true)
        {
            prime[pNum++]=i;
        }
    }
}
struct st
{
    int x;
    int cnt;
} a[11];
int main()
{
    Find_prime();
    int n,num=0;
    scanf("%d",&n);
    if(n==1)printf("1=1\n");
    else
    {
        printf("%d=",n);
        int sqr=(int)sqrt(n*1.0);
        for(int i=0; i<pNum&&prime[i]<=sqr; i++)
        {
            if(n%prime[i]==0)
            {
                a[num].x=prime[i];
                a[num].cnt=0;
                while(n%prime[i]==0)
                {
                    a[num].cnt++;
                    n/=prime[i];
                }
                num++;
            }
            if(n==1)
                break;
        }
        if(n!=1)
        {
            a[num].x=n;
            a[num++].cnt=1;
        }
        for(int i=0; i<num; i++)
        {
            if(i>0)printf("*");
            printf("%d",a[i].x);
            if(a[i].cnt>1)
            {
                printf("^%d",a[i].cnt);
            }
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/102767178