HDU N!Again

题目

Problem Description
WhereIsHeroFrom: Zty, what are you doing ?
Zty: I want to calculate N!..
WhereIsHeroFrom: So easy! How big N is ?
Zty: 1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?
Zty: No. I haven’s finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!
Input
Each line will contain one integer N(0 <= N<=10^9). Process to end of file.
Output
For each case, output N! mod 2009
Sample Input
4
5
Sample Output
24
120

一、分析

2009=4177,有因为41的阶乘里含有41,7,14(2*7)所以41和41之后的阶乘都能整除2009,所以当n>=41时直接输出0即可

二、代码

代码如下(示例):

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<cstring>
using namespace std;

/*
2009=41*7*7,有因为41的阶乘里含有41,7,14(2*7)所以41和41之后的阶乘都能整除2009
*/
int main()
{
    
    
    int n;
    while(scanf("%d",&n)==1)
    {
    
    
        long long sum=1;
        if(n==0) printf("1\n");
        else if(n>=41) printf("0\n");
        else
        {
    
    
            for(int i=1;i<=n;i++)
            {
    
    
                sum=(sum*i)%2009;
            }
               printf("%lld\n",sum);
        }

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wenrenfudi/article/details/114758037