HDU A+B again

杭电 十六进制的一个问题

  • 如果不用c++内置的十六进制输入流,我觉得就我在家的这个状态,我是弄不出来。
  • 就直接用的十六进制输出输入流,开始定义输入输出为int类型,后来提交是WA,然后一直不对,然后看了AC的代码,才知道是定义小了,题中给的A,B 15位,所以用了longlong。

unsigned int 0~4294967295
int -2147483648~2147483647
unsigned long 0~4294967295
long -2147483648~2147483647
long long的最大值:9223372036854775807
long long的最小值:-9223372036854775808
unsigned long long的最大值:18446744073709551615

__int64的最大值:9223372036854775807
__int64的最小值:-9223372036854775808
unsigned __int64的最大值:18446744073709551615

Problem Description
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !

Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.

Output
For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A
+1A 12
1A -9
-1A -12
1A -AA

Sample Output

0
2C
11
-2C
-90

Author
linle

AC代码

#include<bits/stdc++.h>
using namespace std;

int main()
{
    long long m;long long n;
    while(cin>>hex>>m>>n)
    {
        long long sum;
        sum=m+n;
        if(sum>=0){
        cout<<setiosflags(ios::uppercase)<<hex<<sum<<endl;

        }
        else{
        sum=-sum;
        cout<<"-"<<setiosflags(ios::uppercase)<<hex<<sum<<endl;

        }



    }
    //cin>>hex>>m;
    //cout<<m;
}

大佬的两种方法

湖北加油!

发布了18 篇原创文章 · 获赞 0 · 访问量 267

猜你喜欢

转载自blog.csdn.net/qq_42815711/article/details/104146308