PAT--1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4
#include <iostream>
#include <bits/stdc++.h>

using namespace std;

const int maxv = 501;
const int INF = 100000000;

int G[maxv][maxv],n,m,st,ed,weight[maxv];//邻接矩阵、点数、边数、起始点、终点
int d[maxv],w[maxv],num[maxv];//最短距离、最短路径上的最大点权之和、最短路径条数
bool vis[maxv] = {false};//是否已访问过

void Dijkstra(int s)
{
    fill(d,d+maxv,INF);
    memset(num,0,sizeof(num));
    memset(w,0,sizeof(w));

    d[s] = 0;
    //vis[s] = true;
    w[s] = weight[s];
    num[s] = 1;

    for(int i=0; i<n; i++)
    {
        int u = -1,MIN = INF;
        for(int j=0; j<n; j++)
        {
            if(vis[j]==false && d[j]<MIN){
                u = j;
                MIN = d[j];
            }
        }

        if(u==-1) return; //说明剩下的顶点和起点不连通
        vis[u] = true;

        for(int v=0;v<n;v++){
            if(vis[v]==false && G[u][v]!=INF){
                    if(d[u]+G[u][v]<d[v]){
                        d[v] = d[u]+G[u][v];
                        num[v] = num[u];
                        w[v] = w[u]+weight[v];
                    }else if(d[u]+G[u][v]==d[v]){
                        if(w[u]+weight[v]>w[v]){
                            w[v] = w[u]+weight[v];
                        }
                        num[v] += num[u];
                    }


            }
        }
    }

}

int main()
{
    cin>>n>>m>>st>>ed;

    fill(G[0],G[0]+maxv*maxv,INF);
    for(int i=0; i<n; i++)
    {
        cin>>weight[i];
    }

    int c1,c2,l;
    for(int i=0; i<m; i++)
    {
        cin>>c1>>c2>>l;
        G[c1][c2] = l;
        G[c2][c1] = l;
    }

    Dijkstra(st);

    cout<<num[ed]<<" "<<w[ed]<<endl;

    return 0;
}

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/100058374
今日推荐