C++ Pat甲级1003 Emergency (25 分)图+dfs

1003 Emergency (25 分)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

输入:

第一行:n座城市,m条路,从c1走到c2

第二行n个数 :每座城市的救援队数目

接下来有m行 :每行三个字符 ,表示每条路的 起始,终点,长度

输出两个数:从c1到c2不同的最短路径的条数,  可以集齐的最多的救援队数目

#include <cstdio>
#include <cstdlib>
#include <climits>
#include <iostream>
using namespace std;
const int MAX = 501;

int wei[MAX],visit[MAX],map[MAX][MAX];

int mind,cnt,maxt,n;
//初始化图
void init(int n) { //初始化n座城市没被访问过,已经他们之间的距离为Max
	int i,j;
	for(i = 0; i < n; ++i) {
		visit[i] = 0;
		for(j = 0; j < n; ++j) {
			map[i][j] = INT_MAX;
		}
	}
}

void dfs(int st,const int end,int dist,int weit) {
	if(st == end) { //出口
		if(dist < mind) { //若当前距离小于最短距离
			cnt = 1;
			mind=dist; //更新最短距离
			maxt = weit;//更新最多的救援队数目
		} else if(dist == mind) {  //若当前距离等于最短距离
			++cnt; //更新不同的最短距离数目
			if(maxt < weit) {
				maxt = weit;//更新最多的救援队数目
			}
		}
		return;
	}
	//若当前距离大于最短距离, 
	if(dist > mind) return;//这个地方不剪枝的话最后一个case过不去
	int i;
	for(i=0; i<n; ++i) {
		if(visit[i]==0 && map[st][i]!=INT_MAX) {
			visit[i] = 1;
			dfs(i,end,dist+map[st][i],weit+wei[i]);
			visit[i] = 0;
		}
	}

}

int main() {
	int m,st,end,x,y,d,i;
	mind = INT_MAX;
	cnt = 0;
	cin >> n >> m >> st >> end;

	init(n);
	for(i=0; i<n; ++i) {
		cin >> wei[i];//救援队数目
	}
	while(m--) {
		cin >> x >> y >>d; //输入每条路的权
		if(map[x][y]>d) {
			map[x][y] = map[y][x] = d;
		}
	}
	dfs(st,end,0,wei[st]);//初试距离为0
	cout << cnt <<" "<< maxt;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_37503890/article/details/87216784