ayit第十五周训练题b题

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.
 

Input

The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

Output

For each test case, output its divisor number, one line per case.

Sample Input

4
12
0

Sample Output

3
6
#include<stdio.h>
int main()
{
    long long n;
    while(~scanf("%lld",&n)&&n)
    {
        int p[100110]={2,3,5,7},a[100010]={1,1,1,1};
        for(int i=0; i<4;i++)
        {
            if(n%p[i]==0)
            {
                while(n%p[i]==0)
                {
                    a[i]++;
                    n /= p[i];
                }
            }
        }
        printf("%d\n",a[0]*a[1]*a[2]*a[3]);
    }
    return 0;
}

题意  丑数的素因子只有2,3,5,7,给出一个丑数,求丑数的因子有多少

思路,丑数应该满足2^a*3^b*5^c*7^d=n,求出abcd的值向相乘就可以了

猜你喜欢

转载自blog.csdn.net/m0_46628834/article/details/106436620
今日推荐